Contact us on: +44 (0)1432 617 006

The Site Doctor Blog

Footprints in the snow of a warped mind

< Back to Blog

Missing uCommerce tree after upgrade

I recently updated one of uCommerce websites to 6.7.6 and was faced with an empty tree similar to this:

image

There were no errors coming back from TreeDataService.ashx which was just returning an empty array. Checking the logs I saw a lot of these:

2015-09-01 11:17:54,286 [20] WARN  umbraco.BusinessLogic.ApplicationTree - [Thread 30] The tree definition: <add silent="false" initialize="true" sortOrder="10" alias="uc_catalog" application="uCommerce" title="Stores" iconClosed="folder.gif" iconOpen="folder_o.gif" assembly="UCommerce.Umbraco" type="Menu.LoadCatalog" action="" /> could not be resolved to a .Net object type

It turns out that the issue is with a change to the Umbraco tree.config file (stored in /config/) so you need to replace the existing settings to the following to sort it:

<add silent="false" initialize="true" sortOrder="10" alias="uc_catalog" application="uCommerce" title="Stores" iconClosed="folder.gif" iconOpen="folder_o.gif" assembly="UCommerce.Umbraco" type="UCommerce.Umbraco.Menu.LoadCatalog, UCommerce.Umbraco" action="" />
<add silent="false" initialize="true" sortOrder="20" alias="uc_orders" application="uCommerce" title="Orders" iconClosed="folder.gif" iconOpen="folder_o.gif" assembly="UCommerce.Umbraco" type="UCommerce.Umbraco.Menu.LoadOrders, UCommerce.Umbraco" action="" />
<add silent="false" initialize="true" sortOrder="30" alias="uc_marketing" application="uCommerce" title="Marketing" iconClosed="folder.gif" iconOpen="folder_o.gif" assembly="UCommerce.Umbraco" type="UCommerce.Umbraco.Menu.LoadMarketing, UCommerce.Umbraco" action="" />
<add silent="false" initialize="true" sortOrder="40" alias="uc_analytics" application="uCommerce" title="Analytics" iconClosed="folder.gif" iconOpen="folder_o.gif" assembly="UCommerce.Umbraco" type="UCommerce.Umbraco.Menu.LoadAnalytics, UCommerce.Umbraco" action="" />
<add silent="false" initialize="true" sortOrder="50" alias="uc_settings" application="uCommerce" title="Settings" iconClosed="folder.gif" iconOpen="folder_o.gif" assembly="UCommerce.Umbraco" type="UCommerce.Umbraco.Menu.LoadSettings, UCommerce.Umbraco" action="" />

Author: Tim on

Liked this post? Got a suggestion? Leave a comment